use strict;
my $str = ' CostSheetNodeId nodeId;
ItemId itemId;
PmfBatchSize batchSize; // Modification on 02 Jul 2012 by dakaxx - CR4316';
my $regex = qr/([ ]*)([a-zA-Z]\S*)[ ]+(([a-zA-Z])([^\r\n\t\f\v ;]*));.*/p;
my $subst = '\\1public \\2 parm\\U\\4\\E\\5(\\2 _\\3 = \\3)\\n\\1{\\n\\1 _\\3 = \\3;\\n\\1 return \\3;\\n\\1}\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";