import Foundation
let pattern = #"([ ]*)([a-zA-Z]\S*)[ ]+(([a-zA-Z])([^\r\n\t\f\v ;]*));.*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
CostSheetNodeId nodeId;
ItemId itemId;
PmfBatchSize batchSize; // Modification on 02 Jul 2012 by dakaxx - CR4316
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1public \2 parm\U\4\E\5(\2 _\3 = \3)\n\1{\n\1 _\3 = \3;\n\1 return \3;\n\1}\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)