#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[ \[SmokeDetector\]\(https://github\.com/Charcoal-SE/SmokeDetector\) \] (.+): \[(.+)\]\(//[\w\.]+.com/(questions|answers|q|a)/(\d+)\) by \[(.+)\]\(//[\w.]+/users/(\d+)/[\w+-]+\) on `(.+)`"
Local $sString = "[ [SmokeDetector](https://github.com/Charcoal-SE/SmokeDetector) ] Link at end of body, pattern-matching website in body, blacklisted user: [ever striking hazard of diabetic foot?](//drupal.stackexchange.com/questions/175521) by [kanjni juriya](//drupal.stackexchange.com/users/52370/kanjni-juriya) on `drupal.stackexchange.com`"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")