package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[ \[SmokeDetector\]\(https://github\.com/Charcoal-SE/SmokeDetector\) \] (.+): \[(.+)\]\(//[\w\.]+.com/(questions|answers|q|a)/(\d+)\) by \[(.+)\]\(//[\w.]+/users/(\d+)/[\w+-]+\) on `(.+)``)
var str = `[ [SmokeDetector](https://github.com/Charcoal-SE/SmokeDetector) ] Link at end of body, pattern-matching website in body, blacklisted user: [ever striking hazard of diabetic foot?](//drupal.stackexchange.com/questions/175521) by [kanjni juriya](//drupal.stackexchange.com/users/52370/kanjni-juriya) on \`drupal.stackexchange.com\``
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}