import re
regex = re.compile(r"\[ \[SmokeDetector\]\(https://github\.com/Charcoal-SE/SmokeDetector\) \] (.+): \[(.+)\]\(//[\w\.]+.com/(questions|answers|q|a)/(\d+)\) by \[(.+)\]\(//[\w.]+/users/(\d+)/[\w+-]+\) on `(.+)`")
test_str = "[ [SmokeDetector](https://github.com/Charcoal-SE/SmokeDetector) ] Link at end of body, pattern-matching website in body, blacklisted user: [ever striking hazard of diabetic foot?](//drupal.stackexchange.com/questions/175521) by [kanjni juriya](//drupal.stackexchange.com/users/52370/kanjni-juriya) on `drupal.stackexchange.com`"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")