$re = '/\[ \[SmokeDetector\]\(https://github\.com/Charcoal-SE/SmokeDetector\) \] (.+): \[(.+)\]\(//[\w\.]+.com/(questions|answers|q|a)/(\d+)\) by \[(.+)\]\(//[\w.]+/users/(\d+)/[\w+-]+\) on `(.+)`/';
$str = '[ [SmokeDetector](https://github.com/Charcoal-SE/SmokeDetector) ] Link at end of body, pattern-matching website in body, blacklisted user: [ever striking hazard of diabetic foot?](//drupal.stackexchange.com/questions/175521) by [kanjni juriya](//drupal.stackexchange.com/users/52370/kanjni-juriya) on `drupal.stackexchange.com`';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);