const regex = /\d{3}(?!$)\K/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{3}(?!$)\\K', 'gm')
const str = `111222333444
11222333444`;
const subst = `.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);