import re
regex = re.compile(r"\d{3}(?!$)\K", flags=re.MULTILINE)
test_str = ("111222333444\n"
"11222333444")
subst = "."
result = regex.sub(subst, test_str)
if result:
print(result)