import Foundation
let pattern = #"\d{3}(?!$)\K"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
111222333444
11222333444
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)