package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[\*\s+(?<text>(?:\\\]|[^\]])+)\]`)
var str = `Should not match [*A]
Should not match [*refname]
Should not match [*A text] as it is already done in the step before.
But should match [* This is the text in the ref]
And also with escaped brackets in the text [* This is \[important\], I think]`
var substitution = "<ref>$text</ref>"
fmt.Println(re.ReplaceAllString(str, substitution))
}