$re = '/\[\*\s+(?<text>(?:\\\\\]|[^\]])+)\]/';
$str = 'Should not match [*A]
Should not match [*refname]
Should not match [*A text] as it is already done in the step before.
But should match [* This is the text in the ref]
And also with escaped brackets in the text [* This is \\[important\\], I think]';
$subst = "<ref>$text</ref>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;