const regex = /\[\*\s+(?<text>(?:\\\]|[^\]])+)\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\*\\s+(?<text>(?:\\\\\\]|[^\\]])+)\\]', 'g')
const str = `Should not match [*A]
Should not match [*refname]
Should not match [*A text] as it is already done in the step before.
But should match [* This is the text in the ref]
And also with escaped brackets in the text [* This is \\[important\\], I think]`;
const subst = `<ref>$text</ref>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);