import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\*\\s+(?<text>(?:\\\\\\]|[^\\]])+)\\]";
final String string = "Should not match [*A]\n\n"
+ "Should not match [*refname]\n\n"
+ "Should not match [*A text] as it is already done in the step before.\n\n"
+ "But should match [* This is the text in the ref]\n\n"
+ "And also with escaped brackets in the text [* This is \\[important\\], I think]";
final String subst = "<ref>$text</ref>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}