import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\bcout)(s\\b|\\b)";
final String string = "Test de remplacement de cout.\n"
+ "Egalement gout, tache, cout, maitrise. Par contre on ne remplace pas coût ni tâche.\n"
+ "Test également au pluriel de couts et de goût. ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}