const regex = /(\bcout)(s\b|\b)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\bcout)(s\\b|\\b)', 'gmi')
const str = `Test de remplacement de cout.
Egalement gout, tache, cout, maitrise. Par contre on ne remplace pas coût ni tâche.
Test également au pluriel de couts et de goût. `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}