import re
regex = re.compile(r"(\bcout)(s\b|\b)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Test de remplacement de cout.\n"
"Egalement gout, tache, cout, maitrise. Par contre on ne remplace pas coût ni tâche.\n"
"Test également au pluriel de couts et de goût. ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")