#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([[:space:]]+)(.*)$"
Local $sString = " sdf" & @CRLF & _
" asdasd sdf" & @CRLF & _
" ss sdf" & @CRLF & _
"asd" & @CRLF & _
"dsa" & @CRLF & _
" asd" & @CRLF & _
" asd" & @CRLF & _
" asd" & @CRLF & _
" asd" & @CRLF & _
" asd" & @CRLF & _
"asd"
Local $sSubst = "<!--$1-->$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)