const regex = /^([[:space:]]+)(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([[:space:]]+)(.*)$', 'gm')
const str = ` sdf
asdasd sdf
ss sdf
asd
dsa
asd
asd
asd
asd
asd
asd`;
const subst = `<!--$1-->$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);