re = /^([[:space:]]+)(.*)$/m
str = ' sdf
asdasd sdf
ss sdf
asd
dsa
asd
asd
asd
asd
asd
asd'
subst = '<!--$1-->$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result