// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([[:space:]]+)(.*)$").unwrap();
let string = " sdf
asdasd sdf
ss sdf
asd
dsa
asd
asd
asd
asd
asd
asd";
let substitution = "<!--$1-->$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}