# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G(?!^)|[_a-zA-Z0-9-]{2})\K[^@](?=[\w-]*@)/*/gi;t' <<< "example@gmail.com"