import re
regex = re.compile(r"(?:\G(?!^)|[_a-zA-Z0-9-]{2})\K[^@](?=[\w-]*@)", flags=re.IGNORECASE)
test_str = "example@gmail.com"
subst = "*"
result = regex.sub(subst, test_str)
if result:
print(result)