re = /(?:\G(?!^)|[_a-zA-Z0-9-]{2})\K[^@](?=[\w-]*@)/i
str = 'example@gmail.com'
subst = '*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result