$re = '/(?:\G(?!^)|[_a-zA-Z0-9-]{2})\K[^@](?=[\w-]*@)/i';
$str = 'example@gmail.com';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;