import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<.*p>)|(</\\w.*>)";
final String string = "<span class=label ellipsis add-tooltip>Flexible Content Box 1 Professional</span>\n"
+ "<span class=label ellipsis add-tooltip>Flexible Content Box 2 Professional</span>\n"
+ "<span class=label ellipsis add-tooltip>Flexible Content Box 3 Professional</span>\n"
+ "<span class=label ellipsis add-tooltip>Flexible Content Box 4 Professional</span>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}