# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<.*p>)|(</\w.*>)"
test_str = ("<span class=label ellipsis add-tooltip>Flexible Content Box 1 Professional</span>\n"
"<span class=label ellipsis add-tooltip>Flexible Content Box 2 Professional</span>\n"
"<span class=label ellipsis add-tooltip>Flexible Content Box 3 Professional</span>\n"
"<span class=label ellipsis add-tooltip>Flexible Content Box 4 Professional</span>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.