$re = '/\w*$/m';
$str = 'ventas@mobilis.com.mx;242101M205;600;CLP-02-SEN-HARN;3013050;B207;00020068785;H7616I03';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);