re = /\w*$/m
str = 'ventas@mobilis.com.mx;242101M205;600;CLP-02-SEN-HARN;3013050;B207;00020068785;H7616I03'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end