package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^>-]+[^\S\r\n]*->[^\S\r\n]*[^>-]+)?$`)
var str = `word1->word2
word1 -> word2
word1 -> word2->word3
word1 -> word2->word3->Word4
word1->
word1
->word2
my django db->my django db
word1->word2
word1 -> word2
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}