const regex = /^(?:[^>-]+[^\S\r\n]*->[^\S\r\n]*[^>-]+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[^>-]+[^\\S\\r\\n]*->[^\\S\\r\\n]*[^>-]+)?$', 'gm')
const str = `word1->word2
word1 -> word2
word1 -> word2->word3
word1 -> word2->word3->Word4
word1->
word1
->word2
my django db->my django db
word1->word2
word1 -> word2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}