re = /^(?:[^>-]+[^\S\r\n]*->[^\S\r\n]*[^>-]+)?$/m
str = 'word1->word2
word1 -> word2
word1 -> word2->word3
word1 -> word2->word3->Word4
word1->
word1
->word2
my django db->my django db
word1->word2
word1 -> word2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end