$re = '/^(?:[^>-]+[^\S\r\n]*->[^\S\r\n]*[^>-]+)?$/m';
$str = 'word1->word2
word1 -> word2
word1 -> word2->word3
word1 -> word2->word3->Word4
word1->
word1
->word2
my django db->my django db
word1->word2
word1 -> word2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);