# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\S+?=[^'"]\S*[^'"\s]//gm;t' <<< "<p class=MsoListParagraphCxSpFirst style='text-indent:-.25in;mso-list:l0 level1 lfo1'>
<p class='MsoListParagraphCxSpFirst' style='text-indent:-.25in;mso-list:l0 level1 lfo1'>"