$re = '/\S+?=[^\'"]\S*[^\'"\s]/m';
$str = '<p class=MsoListParagraphCxSpFirst style=\'text-indent:-.25in;mso-list:l0 level1 lfo1\'>
<p class=\'MsoListParagraphCxSpFirst\' style=\'text-indent:-.25in;mso-list:l0 level1 lfo1\'>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;