import re
regex = re.compile(r"\S+?=[^'\"]\S*[^'\"\s]", flags=re.MULTILINE)
test_str = ("<p class=MsoListParagraphCxSpFirst style='text-indent:-.25in;mso-list:l0 level1 lfo1'>\n"
"<p class='MsoListParagraphCxSpFirst' style='text-indent:-.25in;mso-list:l0 level1 lfo1'>")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)