re = /\S+?=[^'"]\S*[^'"\s]/m
str = '<p class=MsoListParagraphCxSpFirst style=\'text-indent:-.25in;mso-list:l0 level1 lfo1\'>
<p class=\'MsoListParagraphCxSpFirst\' style=\'text-indent:-.25in;mso-list:l0 level1 lfo1\'>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result