import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.{1025})/?[^/\\n]*[^/.\\n](?:/[^\\n/]*[^/.\\n]){0,253}$";
final String string = "/a\n"
+ "/a.txt\n"
+ "/a/b\n"
+ "/a/b.txt\n"
+ "a\n"
+ "a.txt\n"
+ "a/b\n"
+ "a/b.txt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}