const regex = new RegExp('^(?!.{1025})/?[^/\\n]*[^/.\\n](?:/[^\\n/]*[^/.\\n]){0,253}$', 'gm')
const str = `/a
/a.txt
/a/b
/a/b.txt
a
a.txt
a/b
a/b.txt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}