$re = '/^(?!.{1025})/?[^/\n]*[^/.\n](?:/[^\n/]*[^/.\n]){0,253}$/m';
$str = '/a
/a.txt
/a/b
/a/b.txt
a
a.txt
a/b
a/b.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);