package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([1-9]\d{0,3}|1\d{4}|2[0-4]\d{3}|25000)$`)
var str = `Matches
-------
1
9
10
100
999
1000
9999
10000
20000
24999
25000
Doesn't match
-------------
0
01
00009
25001
99999
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}