const regex = /^([1-9]\d{0,3}|1\d{4}|2[0-4]\d{3}|25000)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([1-9]\\d{0,3}|1\\d{4}|2[0-4]\\d{3}|25000)$', 'gm')
const str = `Matches
-------
1
9
10
100
999
1000
9999
10000
20000
24999
25000
Doesn't match
-------------
0
01
00009
25001
99999
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}