import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([1-9]\\d{0,3}|1\\d{4}|2[0-4]\\d{3}|25000)$";
final String string = "Matches\n"
+ "-------\n"
+ "1\n"
+ "9\n"
+ "10\n"
+ "100\n"
+ "999\n"
+ "1000\n"
+ "9999\n"
+ "10000\n"
+ "20000\n"
+ "24999\n"
+ "25000\n\n"
+ "Doesn't match\n"
+ "-------------\n"
+ "0\n"
+ "01\n"
+ "00009\n"
+ "25001\n"
+ "99999\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}