# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d\d\d\d)-(\d\d)(-\d\d\D)?//g;t' <<< "ABC 2012-10-01
DEF 2013-07-10
2018-01-21
ABG 2015-10-30A
EDF 2019-01-19B
ABC/DEF/GEH 2019-01-19A
"