const regex = /(\d\d\d\d)-(\d\d)(-\d\d\D)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d\\d\\d\\d)-(\\d\\d)(-\\d\\d\\D)?', 'g')
const str = `ABC 2012-10-01
DEF 2013-07-10
2018-01-21
ABG 2015-10-30A
EDF 2019-01-19B
ABC/DEF/GEH 2019-01-19A
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);