// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d\d\d\d)-(\d\d)(-\d\d\D)?").unwrap();
let string = "ABC 2012-10-01
DEF 2013-07-10
2018-01-21
ABG 2015-10-30A
EDF 2019-01-19B
ABC/DEF/GEH 2019-01-19A
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}