use strict;
my $str = 'ABC 2012-10-01
DEF 2013-07-10
2018-01-21
ABG 2015-10-30A
EDF 2019-01-19B
ABC/DEF/GEH 2019-01-19A
';
my $regex = qr/(\d\d\d\d)-(\d\d)(-\d\d\D)?/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";