#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:\+45|\(\+45\)|\(0045\)|0045)|(?!00))\d{8}$"
Local $sString = "+4512345678" & @CRLF & _
"(+45)12345678" & @CRLF & _
"004512345678" & @CRLF & _
"(0045)12345678" & @CRLF & _
"12345678" & @CRLF & _
"00451234" & @CRLF & _
"004512345678" & @CRLF & _
"004612345678" & @CRLF & _
"12345678" & @CRLF & _
"00441234" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")