import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:\\+45|\\(\\+45\\)|\\(0045\\)|0045)|(?!00))\\d{8}$";
final String string = "+4512345678\n"
+ "(+45)12345678\n"
+ "004512345678\n"
+ "(0045)12345678\n"
+ "12345678\n"
+ "00451234\n"
+ "004512345678\n"
+ "004612345678\n"
+ "12345678\n"
+ "00441234\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}