using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:\+45|\(\+45\)|\(0045\)|0045)|(?!00))\d{8}$";
string input = @"+4512345678
(+45)12345678
004512345678
(0045)12345678
12345678
00451234
004512345678
004612345678
12345678
00441234
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}