$re = '/^(?:(?:\+45|\(\+45\)|\(0045\)|0045)|(?!00))\d{8}$/m';
$str = '+4512345678
(+45)12345678
004512345678
(0045)12345678
12345678
00451234
004512345678
004612345678
12345678
00441234
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);